#1 03.09.2017 12.47.41

Xabre
Administrator
Iz: Užice
Registrovan: 14.04.2013
Poruke: 597

Izmena putanje Perl biblioteka

Paket Perl sada koristi verzioniranu putanju za kompajlirane module. Ovo znači da moduli koji su kompajlirani za nepoklapajuću verziju neće biti učitani i moraju ponovo biti izgrađeni.

Pakmenova kuka upozorava na pogođene module tokom nadogradnje prikazom izlaza nalik ovome:

UPOZORENJE: '/usr/lib/perl5/vendor_perl' contains data from at least 143 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/vendor_perl'
 

Morate ponovo izgraditi sve pogođene module za novi Perl da bi ih mogli ponovo koristiti. Izmena takođe pogađa module instalirane direktno putem CPAN.

Molimo imajte u vidu da je ponovna gradnja modula već bila zahtevana za veće nadogranje i pre ove izmene, međutim sada Perl neće pokušati da učita module i dobiti čudne greške o neupehu.

Ukoliko sistem gradnje nekog softvera ne otkrije ovu promenu automatsski, možete upotrebiti perl -V:vendorarch u vašem PKGBUILD-u za upit ispravne putanje. Takođe postoji i sitearch za softver koji se ne pakuje Pakmenom.


HP ProBook 450 G1 |  Intel Core i3-4000M | 8GB DDR3 RAM @1600MHz | Intel HD4600 + AMD Radeon 8750M | KDE plasma 5
Life's a bitch, but root password helps.
<*>Univerzalno rešenje svih problema: RTFM/W - Read The Fucking Manual/Wiki<*>

Odjavljen

Podnožje foruma

Pokreće me FluxBB